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About this document
These materials are part of the Multimedia Training Kit (MMTK). The MMTK provides an
integrated set of multimedia training materials and resources to support community media,
community multimedia centres, telecentres, and other initiatives using information and
communications technologies (ICTs) to empower communities and support development
work.

Copyright information
This unit is made available under the Creative Commons Attribution-ShareAlike License. To
find out how you may use these materials please read the copyright statement included with
this unit or see
http://creativecommons.org/licenses/by-sa/1.0/legalcode.
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Introduction
In this unit we will be developing all the basic skills you need for creating word processed
documents using OpenOffice.org Writer. This is the word processing arm of the
OpenOffice.org suite – a collection of open source office productivity tools.  

This unit does not cover every aspect of OOo Writer, but should leave you with enough
familiarity and confidence  to explore more features on your own.
More specifically we will be looking at:

• Creating new documents: opening, closing and saving options
• Writing: deleting, undoing, copying and pasting
• Formatting: editing fonts, paragraphs,  colouring, and styles
• Adjusting the settings for the way you like to work: spelling, viewing and page sizing
• Problem solving – how to find solutions not covered in this unit, understanding the menu-

bars, and using Help.

Creating new documents
All word processing work is organised into documents – these are the separate pieces of work
that you write. You may think of them as:

• Letters
• Reports
• Minutes of meetings
• Project proposals
• CVs / resumés
• Any piece of work that needs documenting separately from other work

The blue bar at the top of the page displays the file name of the document:

In the example above, mmtk_ooo_writer_1_handout is the name the writer gave this
documents; .sxw is the file extension which tells you that it is an OOo Writer file. 

In general all the work we do on computers gets stored as units called files. 

• Word processed files are called documents
• Picture files are called images
• Matrix files are called spreadsheets

The document's file name is the name that the file will go by once it is stored in a folder in your
computer's memory. It needs to be something which allows you to easily identify its contents,
and that distinguishes it appropriately from other files.

The empty document (rather like a blank page) is ready for you to start writing on straight
away. The cursor blinks in the top left hand corner of the page, a margin's width away from the
edge of the page. This is where your work begins and it will be committed to the computer's
memory as soon as you save the document. 

Every time you add new text or edit old text, you are changing the document from the version
which was last saved. In order for those changes to be securely recorded in the computer's
memory, you must always remember to save your work.
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There are circumstances, however, where simple replacement is not appropriate. These
include:

• Needing to create different versions of the document e.g. versions altered for different
readers.

• Needing to save the document in a different location from the original one – perhaps on a
floppy disk or CD, or network space, so that you or others can access it from another
workspace.

To keep a copy of the unchanged (previous version) document as well as a copy of this newly
edited one, you must Save As.

Review

File > New > Text Document : creates a new empty, untitled document for you to work on.

File > Open : opens the file (document) that you locate in your computer's filing system. The
last saved version of the document will open.

File > Close :  closes the document you are working on. If changes have been made since
your last save, you will be prompted to save or discard those changes.

File > Save : saves the document you are currently working on, replacing the previously
saved version with this updated one – in the same place with the same name.

File > Save As... : saves an updated version of a document in a different location, with a
different name, from the previously saved version.

Writing: deleting, undoing, copying and pasting
It is inevitable that as you write, you will occasionally make typing errors. You may also rethink
the wording of some sentences, or indeed whole paragraphs, when you review your work.
Ooo Writer offers various ways to delete, rewrite and move text around.

The following are probably already familiar to you:

The Delete key deletes the character in front of the cursor.

The Backspace key deletes the character behind the cursor.

Deleting one character at a time may be appropriate for small typos, but there are more
efficient ways of editing bigger chunks of text. Highlighting the text you want to remove is
often a more efficient way of working. This can be done: 

• By dragging your mouse across the relevant section
• By double-clicking on a word – to highlight the word 
• By triple-clicking on a word – to highlight the line that it's in
• By typing Control + A, or Edit > Select  All to highlight the entire document

Once highlighted, text can be

• Deleted using the Delete or Backspace key
• Dragged to another part of the document using the mouse
• Cut out of the document and pasted back in a different place where the cursor has been

positioned, using the Cut, Copy and Paste tools

The actions of cutting text and then pasting it elsewhere  involve the selected bits of text being
stored on the computer's clipboard – a special part of the computer's memory - which is used
for storing pieces of data (words, numbers, pictures, sounds) temporarily, so that they can be
easily retrieved for re-use.
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We can also copy text onto the computer's clipboard without cutting it out of the document
first. Copying is a useful tool for words or sections of the document that you want to repeat
elsewhere.

Text which has been cut or copied will remain in the computer's clipboard memory for pasting
into the document wherever you choose, until it is replaced by something else – i.e. until you
select some other piece of text and copy it using the copy icon.

Word processing is all about making the work of writing and producing documents easier and
more efficient. Ease of use  is often about finding ways of working which feel the most
comfortable. These ways of working can vary from one person to another, and so OOo Writer
often provides a number of different ways of doing exactly the same word processing task. By
experimenting with the different methods, you will quickly see which feel most comfortable for
your style of working.

See the review table below for alternative ways of carrying out all the tasks we have looked at
so far.

Most of the tasks listed can be achieved using any one of three different methods: 

• Clicking on a toolbar icon or 
• Choosing an item from a menu or 
• Typing in a combination of different keys (usually the Control key + one other) 

Review

Task Toolbar
icon

Menu route Keystroke

New document File > New > Text Document Control + n

Open
document

File > Open Control + o

Save
document

File > Save Control + s

Close
document

File > Close Control + w

Select All Edit > Select All Control + a

Undo Edit > Undo Control + z

Cut Edit > Cut Control + x

Copy Edit > Copy Control + c

Paste Edit > Paste Control + v
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Formatting: fonts and paragraphs
By far the most obviously sophisticated aspect of word processing is the way it allows you to
format your work in all kinds of different styles. You can choose which fonts you write your
work in, how you space the lines of text, how to display lists of items, which colours your work
appears in, which colours it appears on! There are numerous options for styling your
document so that it looks the way you want. 

Editing fonts

Fonts refer to the lettering style of your work. OOo Writer lets you control the font style, size
and colour for any text in your document. You can choose to keep this the same throughout a
document or vary it for different paragraphs, lines, words, or letters. On opening a document
you can see what default font has been set by OOo Writer, by looking in the font box on the
formatting toolbar.

Review
• Changing the font style when the cursor is blinking will affect all text that you type from the

point where the cursor blinks, onwards. It will not affect text which is already typed.
• Changing the font style when text is highlighted will affect only that text which is

highlighted.

Mastering these methods of changing the font style  is relevant for a number of other
formatting options. We will use the same procedure to change the font size, emphasis (bold,
italic or underlining), and colour. 

Remember, these tools are there to help you make your work easier to read, not more
confusing.

By emphasising headings using bold, and larger font sizes, they can stand out and
make skim-reading easier.

By italicising certain words, you can make it clear that these are key words to check – perhaps
they are glossaried or from another language.

Similarly, careful use of other colours and font styles can make your document eye-
catching and give the work a look which conveys a certain mood and style.

Check the review sheet below for alternative methods of formatting:

Review
Task Toolbar icon Menu route Keystroke
Font style Format > Character > Font tab _

Font size Format > Character > Font tab _

Font colour A Format > Character > Font tab _

Font highlight
colour

A Format > Character >
Background tab

_

Bold B Format > Character > Font tab Control + b

Italic i Format > Character > Font tab Control + i
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Review
Underline U Format > Character > Font

Effects tab
Control + u

Formatting paragraphs 

As we have seen text formatting can be applied to an individual character, a selection of
words, or an entire document. Paragraph formatting, on the other hand, relates specifically to
the layout of an entire paragraph.

It concerns your choices around:

• Line spacing
• Background colouring
• Text justification (left, right, centered, justified)
• Line indentation

Again OpenOffice.org applies default settings for all of these options. So you don't need to set
things up before getting on with your document.

The Format > Paragraph dialogue box is full of information about the formatting of the
paragraph within which the cursor is blinking. And it is this box that you need to return to in
order to change that formatting. As with other OpenOffice.org dialogue boxes, it contains a
number of tabs, each of which offers ways of altering the settings around an aspect of the
paragraph formatting.

Notice how positioning a blinking cursor in any paragraph allows you to change settings for
that whole paragraph.

Conversely, highlighting and selecting just a part of the paragraph, will not limit the effect of
the formatting to the selection only. It will be applied to the whole paragraph.

Paragraph formatting is always applied to a whole paragraph. In order to understand what the
computer understands as the beginning and end of a paragraph, it is helpful to switch on Non-
Printing Characters. This is done by clicking on the ¶ button on the main toolbar. The button
toggles non-printing characters on and off. When they are switched on, a  ¶ will be displayed
at the end of every paragraph (wherever you have used the enter button to create a paragraph
break). You can then easily see the section of text that paragraph formatting will be applied to
if you make any changes.

Whilst the paragraph dialogue box works like a control panel for detailed altering  of your
paragraph, there are more direct ways for changing  paragraph basics.

See the chart below for alternative ways of altering basic paragraph settings: 
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Review
Task Toolbar

icon
Menu route Keystroke

Left justified
text

Format > Paragraph >
Alignment tab

Control + l

Right justified
text

Format > Paragraph >
Alignment tab

Control + r

Centered text Format > Paragraph >
Alignment tab

Control + e

Justified text Format > Paragraph >
Alignment tab

Control + j

Increase left
hand indent

Format > Paragraph > Indents
and Spacing tab

_

Background
shading

Format > Character >
Background tab

_

Single line
spacing

_ Format > Paragraph > Indents
and Spacing tab

Control +1

1.5 line
spacing

_ Format > Paragraph > Indents
and Spacing tab

Control +5

Double line
spacing

_ Format > Paragraph > Indents
and Spacing tab

Control +2

Putting it all together – understanding styles

Any document you work on will be shaped by a number of sets of formatting decisions. We
call these sets Styles. 

We have seen how the Default style set up by OOo Writer applies a group of formats at the
same time, to any new document you open.

You can  use these existing (pre-defined) OOo Writer styles as they are, or alter their formats.
You can also create new styles with other names.

The advantage of applying styles to your document, is that you are dealing with several
different formats in one click. See the chart below for the formats that make up some of OOo
Writer's styles:

Style name Spacing Alignment Font Emphasis
Default Single Left justified Arial, 10 pt No emphasis
Heading1 Single Centered Arial, 16 pt Bold
Footer Single Left justified Arial, 9 pt No emphasis
Quotation Thornton, 12 pt Italic
Subtitle Single Centered Albany, 14 pt Italic

Whichever style you are working with, it is always possible to override the formatting by
manually changing the formatting settings, as we did at the beginning of this section.
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Adjusting the settings for the way you like to work 
A large part of successful word processing is finding a comfortable way of working with the
tools. The more intuitive you find the way of handling them, the faster and more effectively
you'll use them. In this section we will look at various ways of adjusting the OOo Writer
working environment.

Your preferences will be informed by:

• Other word processing systems you have used and become accustomed to. 
• How good you are at typing and spelling; whether you are working largely in your mother

tongue or a foreign language.
• The way in which you plan your work – stream of consciousness first followed by careful

redrafting and editing, or careful outline first followed by “final-draft” writing.
• The sorts of documents you tend to write – short memos, decorative invitations, business

letters, long reports, meeting minutes, or project proposals.

Spelling

There is a standard spell checker in OOo Writer which you can start by clicking on the icon on
the main toolbar: 

This works by checking your spelling against a dictionary that comes as part of the
OpenOffice.org package. If you have the English version loaded on your system, then the US
English dictionary will be set up ready for use. If you want to use another English (e.g. UK) you
will have to install that as an extra manually. 

To check which dictionaries are installed and to choose the correct one for your document,
Choose Tools > Spellcheck > Check (this dialogue only appears if the spell checker finds a
spelling mistake) then click Options. User-defined dictionaries lists the available user
dictionaries. Mark the user dictionaries that you want to use to check spelling and
hyphenation.

AutoCorrect/AutoFormat

As well as the spell checker there are other options available for help with spelling, most of
which you can explore in the AutoCorrect dialogue box. To access this tabbed dialogue box,
click on Tools > AutoCorrect/AutoFormat.

A few of the most commonly used features are explained below:

Replace

If you switch on the replace tool OOo Writer will correct typing errors as you make them. It will
recognise when mistakes are made and correct them as soon as you press the space bar or a
punctuation mark on completing the misspelled word.

You can manually add to the list of words that are automatically corrected by using the
Replace tab in the AutoCorrect/AutoFormat dialogue box. You can also add to it as you
have your work spell checked. The spell checker gives you the option to add any misspelled
words to the AutoCorrect list as it goes through your work. 

Options

If AutoCorrect/AutoFormat is turned on, certain text will automatically be
corrected/reformatted as you type. For example, by default if you type two capitals at the
beginning of a word (e.g. BEginning) this will be automatically corrected. The Options
dialogue lets you select which common formatting problems should be automatically
corrected. 
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Word completion

If you switch on the word completion tool, as you type your document, OOo Writer will
automatically build up an intelligence about the longer words you tend to use. It will compile a
list of any words over 5 letters long that you are using. This list can always be found in the
Word Completion tab dialogue box.

It will use this intelligence to complete the words you are typing as you type them. You will
notice entire words appearing (with remaining letters highlighted in yellow) as you begin typing
the first few letters of words contained in the list, e.g.  

If you want to accept the complete word as suggested by OOo Writer, you must use the End
or Enter key (depending on which was given in the Word Completion dialogue box). 

Getting to know and customize the OOo Writer workspace

As you become more familiar with the OOo Writer workspace, you can start to strike a
balance between the need to have an uncluttered workspace on the screen and the need to
have your favourite tools within easy reach.

This is largely about clearing away the unnecessary tools, and knowing how to find them
again, should they become more relevant.

As well as the main toolbars listed in the View menu, there are a number of fly-out toolbars
that you can select by long-clicking on the icons that have tiny green arrows in the right hand
corner. These include the Forms, Drawing, and Stylist toolbars. 

As with the icons on all toolbars, their function can always be revealed by holding the mouse
over the icon, without clicking.

Other options on the View menu will allow you to hide/include text boundaries and non printing
characters. You can also choose to zoom in on your text so that it appears bigger on the
screen. 

Navigating OOo Writer on your own
There are various ways of moving on from this introduction to using OOo Writer.

• Attend a course based on the next unit level
• Study Jean Hollis Weber's Taming OpenOffice.org Writer
• Explore, experiment with, and use OOo Writer 

This last option is best done by spending time getting to know the menus of the top menu bar
and the right-clicking menus.

Understanding how to use OOo Writer is as much about understanding the organisation and
logic of the tools as it is about remembering how to operate them.

If you can get a feel for the system, you will build up a sound OOo Writer knowledge base. 

Take the time to play around with these menus and test the different options. Armed with the
knowledge of how to save your work  (  or Control + s) and how to undo unwanted changes 
( or Control + z), there is really very little to worry about whilst you experiment.
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